Stop IE Prompting To Confirm Certificate

IT Support Forum Forums Windows Windows 7 Applications Stop IE Prompting To Confirm Certificate

This topic contains 0 replies, has 1 voice, and was last updated by  Webmaster 5 months, 2 weeks ago.

  • Author
    Posts
  • #1885

    Webmaster
    Keymaster

    By default, IE displays the following prompt when you try to access a website secured with a certificate:

    Windows Security
    Confirm Certificate
    Confirm this certificate by clicking OK. If this is not the correct certificate, click Cancel

    To disable the Confirm Certificate pop up:

    • Ensure that when you installed the certificate you didn’t have the Enable strong private key protection. You will be prompted every time the private key is used by an application if you enable this option. This may mean you have to reinstall the certificate on the client PC without the box ticked.
    • Enable the following GPO, then do a gpupdate /force or reboot the PC that is asking you to confirm the certificate:

      Computer Configuration -> Policies -> Administrative Templates -> Windows Components -> Internet Explorer -> Internet Control Panel -> Security Page -> (Zone the website is in) -> Do not prompt for client certificate selection when no certificate or only one certificate exists.

    Be sure to enable the policy, then set the dropdown to enabled after enabling the policy.

You must be logged in to reply to this topic.