Remote Desktop Is Slow To Connect

IT Support Forum Forums Windows Windows Server 2012 Networks, Firewall and Sharing Remote Desktop Is Slow To Connect

This topic contains 0 replies, has 1 voice, and was last updated by  Webmaster 4 months, 3 weeks ago.

  • Author
    Posts
  • #2312

    Webmaster
    Keymaster

    If Remote Desktop is slow to connect, most likely this is caused by the Large Send Offload Version 2 on your Network Adapter. To fix the slow Remote Desktop initial connection, under the properties of the network adapter click the Configure button then click Advanced. click on Large Send Offload Version 2 (ipv4) (assuming you’re using IPv4) and set it to Disabled.

    I have found that this fixed my slow Remote Desktop issue, but I’ve read online that other people also set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters to DisableTaskOffload DWORD value 1

    Addendum: It’s worth noting that disabling Large Send Offload Version 2 also caused my Microsoft Access MDB database to become unreadable by a program that connects to the MDB over the network on a network share hosted on the server with Large Send Offload Version 2 disabled. I ended up re-enabling it to fix the legacy application at the cost of my Remote Desktop being slow to connect to the session.

You must be logged in to reply to this topic.