RDP Slow To Connect – Just A Moment

IT Support Forum Forums Windows Windows 10 Troubleshooting RDP Slow To Connect – Just A Moment

Tagged: , ,

This topic contains 0 replies, has 1 voice, and was last updated by  Webmaster 10 months, 2 weeks ago.

  • Author
    Posts
  • #1650

    Webmaster
    Keymaster

    If your RDP client is slow to connect and just says Just a moment before giving you the option to log in, then you’ve probably got an RDP client that’s expecting to communicate with NLA (Network Level Authentication), but connecting to a server that doesn’t support it.

    To fix the slow RDP client and get rid of the Just a moment message, either disable NLA in the RDP client or enable NLA on the server you are connecting to (preferable).

    Note that disabling NLA on the client will make the connection less secure.

You must be logged in to reply to this topic.