404.2: The page you are requesting cannot be served because of the ISAPI and CGI

IT Support Forum Forums Web Servers IIS Troubleshooting 404.2: The page you are requesting cannot be served because of the ISAPI and CGI

This topic contains 0 replies, has 1 voice, and was last updated by  Webmaster 3 years, 1 month ago.

  • Author
    Posts
  • #272

    Webmaster
    Keymaster

    When trying to view a .NET website using ISAPI / CGI, you get:

    404.2: The page you are requesting cannot be served because of the ISAPI and CGI

    This is because the default setting for ISAPI and CGI through .NET is disabled. To remove the .NET restriction in ISAPI and CGI:

    1. Open IIS using the inetmgr command on your web server
    2. Select the web server you are using
    3. Click on ISAPI and CGI Restrictions
    4. Enable the .NET version that your website is written in

    You should now, no longer get the 404.2: The page you are requesting cannot be served error.

You must be logged in to reply to this topic.